Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Transpose Columns Component

I am transposing a wide table, approx 300 columns. I use text mode (a great feature) to add the columns and upon validation I get the following error message:

org.postgresql.util.PSQLException: ERROR: Assert
Detail:
-----------------------------------------------
error: Assert
code: 1000
context: m_count >= 0 - invalid m_count
query: 259540
location: xensem.hpp:349
process: padbmaster [pid=21394]
-----------------------------------------------

If I back the number of columns down to 202 from 300, the validation succeeds. The union statement being generated is pretty big, about 31K in size. Is this error caused by some kind of limit in the component or in Redshift? Is there some parameter I can set to fix it or do I have to split the transformation into two with one doing the first 150 and the second doing the remainder.

3 Community Answers

Matillion Agent  

Chris Tuerpe —

Stephen,
Thanks for contacting support. The error that you are getting is not generated from Matillion, it is generated from the database. I would like to recreate the error.
Would you be willing to forward along the export of the matillion job and the create statement of the source table.

Thanks
Chris


stephen miller —

I agree, it is definitely generated by the database. I was more wondering if you'd seen it before and if there was a parameter that redshift has that can be set i.e. size of SQL buffer etc. I'll open a support ticket and attach the code so it is easier to communicate. I'll reference this thread.

Thanks Chris


Matillion Agent  

Chris Tuerpe —

Stephen, Thanks, Most likely that Redshift is running out of some resource. You may want to raise a ticket with AWS. I will be on the look out for that ticket.
Thanks
Chris

Post Your Community Answer

To add an answer please login